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CSCI 4448/5448: OBJECT-ORIENTED ANALYSIS & DESIGN

LECTURE 11 — 09/27/2011
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Goals of the Lecture

Present an introduction to the Android Framework

Coverage of the framework will be INCOMPLETE

We’ll provide additional coverage after the midterm
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Android

open source software toolkit created, updated and 
maintained by Google and the Open Handset Alliance

2.X series and previous: mobile phones

3.X series: extended to also support tablets

We’ll be covering 3.X in this lecture
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Tim Bray’s What Android Is

The next few slides paraphrase a November 2010 blog post by 
Tim Bray; be sure to read the original!

What Android Is

4

Tim Bray is a co-inventor of 
XML and is currently 
employed by Google to work 
on Android

http://www.tbray.org/ongoing/When/201x/2010/11/14/What-Android-Is
http://www.tbray.org/ongoing/When/201x/2010/11/14/What-Android-Is
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Big Picture View (I)
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Android is a layered software framework

At the bottom is the Linux kernel that has been 
augmented with extensions for Android

the extensions deal with power-savings, essentially 
adapting the Linux kernel to run on mobile devices

Next are a set of standard libraries

Apache HTTP, OpenGL ES, Open SSL, SAX, WebKit, 
SQLite, libc, FreeType, etc.
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Big Picture View (II)
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Android is a layered software framework (cont.)

The third layer is the Android Framework

These classes and services uniquely define Android

Examples include Activity Manager, Search 
manager, Notification Manager, Media Player, 
Widow Manager, etc.

These services are used by developers to create 
Android applications that can be run in the emulator 
or on a device
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Big Picture View (III)
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Android is a layered software framework (cont.)

The fourth layer are actual Android apps and 
services

These applications are executed by the Dalvik virtual 
machine, essentially a Java virtual machine but with 
different bytecodes

Note: Android also supports native applications 
written in C/C++ (think games); I will not be 
covering that aspect of Android programming
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Android Applications
Android applications get distributed in a .apk file

APK stands for “Android Package”

It is simply a zip file that has a particular file structure (similar to 
JAR files that take snapshots of the file system)

An APK contains

The Android Manifest file (an XML file with lots of 
metadata)

A Resource bundle containing sounds, graphics, etc.

The Dalvik classes that make up your application
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Android Benefits (I)

Proponents of Android point to the following benefits

An open & free development platform

Handset makers can use it without royalty and 
customize to their hearts content

Component-based architecture

Lots of default components (such as the on-screen 
keyboard) can be replaced straightforwardly
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Android Benefits (II)

Proponents of Android point to the following benefits

Lots of services: location, sql, maps, web, etc.

Well managed applications; isolated from each other to 
protect data and provide security; operating system can 
quit programs as needed to ensure good performance 
on mobile devices

Portability: To support a new device, a company has to 
port the virtual machine; Android apps (Dalvik) then 
execute on the new device with little to no modification

10



© Kenneth M. Anderson, 2011

Android Installation

See Installing Android on the What’s New Page

Major steps

Install Java (if needed); JDK 5.0 or higher

Download and install Eclipse

Download the Android SDK

Download a version of the Android Platform

Install and Configure the Eclipse Android plug-in

11

http://www.cs.colorado.edu/~kena/classes/5448/s11/whats-new/installing-android.html
http://www.cs.colorado.edu/~kena/classes/5448/s11/whats-new/installing-android.html
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Before developing… (I)

Create an Android Virtual Device

The emulator for Android is called a “virtual device”

When you first start developing for Android, you will 
need to create one;

then Eclipse will build .apk files that can be stored and 
executed on that device (essentially they run on an 
imaginary phone that has been configured to have a 
certain amount of memory and UI and that targets a 
particular version of the Android API

12
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Before developing… (II)

To create a virtual device

Launch Eclipse

Select Window ⇒ Android SDK and AVD Manager

Select “Virtual Devices” in the resulting window

Click “New…”

Configure the resulting screen (defaults are fairly 
obvious) and click “Create AVD”

13



© Kenneth M. Anderson, 2011

Hello World (I)

As with all advanced frameworks, the standard application 
template is configured to ensure that you have a working 
application from the start

In Eclipse

Click the new Android project icon 

Fill out the resulting dialog with the values on the next 
slide

Click “Finish”

14



© Kenneth M. Anderson, 2011

Hello World (II)

Project Name: HelloWorld

Build Target: Android 3.2 (or whatever you downloaded)

Application Name: Hello From Android

Package Name: org.example.hello

Activity: Hello

Min SDK: 13 (or whatever you downloaded; 13 is the 
current latest SDK)

15
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Hello World (III)
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Zoom in on dialog box on 
the right to confirm what 
you should be seeing on 
your machine.

Then click “Finish”.
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Meet the Android Project

17

On disk, this virtual 
representation in Eclipse 
translates to 19 files stored in 
19 directories

Only 2 Java source code files 
however! Hello.java and the 
(automatically updated) R.java

Demo
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Run the Program

18

As mentioned previously, this application is ready to run

So, right click on the project icon

And select Run As ⇒ Android Application

The first time the emulator launches, it takes a long 
time; It may then show a “lock screen” that needs to be 
unlocked; It will then show our marvelous application!
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Hello From Android
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We can see our 
application name across 
the top.

But where did the string 
“Hello World, Hello!” 
come from?
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Not in Hello, our initial Activity
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Lots of interesting info here 

We see the package that 
we specified in line 1

We see that activities come 
from the package 
“android.app”

We see hints of a life cycle 
model: “onCreate”

But no sign of the 
string “Hello World, 
Hello!”

A clue: R.layout.main
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Not in R.java
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Egads, run screaming!

Besides, it says “Auto-
generated file. Do not 
Modify.”

Autogenerated from what?
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Double Click layout.xml in res/layout
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Bingo!

But what are we seeing?

Click the tab main.xml for a 
view of the actual xml file
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Fun with XML
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Again, lots of fun information; Our user interface is 
defined by a vertical “LinearLayout”, i.e. in a straight 
line, that contains a single widget, a TextView

And, the value of the TextView is “@string/hello”
Hmm… that’s not the string we saw in the GUI
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The Likely Suspect:
    res/values/strings.xml
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Bingo!

The slightly 
ungrammatical 
phrase of “Hello 
World, Hello!” was 
hiding in the 
strings.xml file that is 
a part of our app’s 
standard resources
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What have we learned?
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Android Apps make use of classes and resources

At least one of the classes comes from “android.app” and is 
called Activity

When an activity is created, the operating system calls its 
onCreate() method

One of the things it can do is set the current layout

Layouts are specified in XML files and make use of strings 
defined in other XML files

There are graphical editors for these XML files
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Let’s learn more…

The key parts of the Android Framework are

The activity manager : starts, stops, pauses and resumes 
applications

The resource manager : allows apps to access the 
resources bundled with them

content providers: objects that encapsulate data that is 
shared between applications

Location Manager and Notification Manager (events)

26
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Application Stack

When a user launches an Android application

A linux process is created, containing an activity

That activity’s layout takes over the entire screen 
except for the status bar

The user may then switch to a different screen in the 
application (i.e. a different activity) or to a new 
application all together

Screens are “stacked” and the user can navigate back 
to the previous screen by pressing the “back” button

27
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Application Life Cycle (I)

In Android, an application is a set of activities with a Linux 
process to contain them

However, an application DOES NOT EQUAL a process

Due to low memory conditions, an activity might be 
suspended at any time and its process discarded

The activity manager remembers the state of the 
activity however and can reactivate it at any time

Thus, an activity may span multiple processes over 
the life time of an application

28
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onCreate()

onStart()

onResume()

onPause()

onStop()

onDestroy()

Running

Not 
Running

Process
Killed

sent to background

no longer visible

sent to
foreground

onRestart()about to be
displayed

can start
interacting
with user

just started

being redisplayed from
a stopped state

Activity Life 
cycle

onStop() and 
onDestroy() 
are optional 
and may 
never be 
called

Thus, if your 
app needs to 
save data 
persistently, 
the save 
needs to 
happen in 
onPause()
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Let’s see this in action

Create new application

Project Name: Life Cycle

Build Target: Android 3.2 (or whatever you downloaded)

Application Name: Activity Life Cycle

Package Name: org.example.lifecycle

Activity: LifeCycle

Min SDK: 13 (or whatever you downloaded)
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Modify LifeCycle.java

31

Add a method for each of the life 
cycle events

Each method should call its 
counterpart in the superclass and 
then call Log.i with a tag and a 
message.

Run the app and switch to the 
Debug perspective; watch the 
events appear in the Log (because 
of the tag, we can use a filter)
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Intents

32

The other primary concept for an application is an Intent

Intents are used to describe a specific action

An activity will create an Intent and then invoke it

Intents can be used to pass information between 
activities, as we will see

Intents can also be used to launch other applications, such 
as the built-in web browser or the built-in camera

We’ll see simple uses of Intents next and explore them more in 
lectures after the midterm
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Switching Between Activities

We will now design a simple application that has three 
activities (and thus three screens). A start screen will 
contain two buttons that let you jump to the other two 
screens. Screen one and screen two will each contain a 
button that takes you to the other screen.

We won’t provide a way to go back to the start screen

Since we have multiple activities, we’ll use intents to switch 
between them

33
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Step 1

Create the Application

Project Name: Screen Switcher

Build Target: Android 3.2

Application Name: Screen Switcher

Package Name: org.example.screenswitcher

Activity: StartScreen

Min SDK: 13

34
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Step 2

Need to modify the default layout

Add label for application name and screen name

Add buttons to go to screen one and screen two

Resize text, add margins, and center elements on screen

New concepts

Each widget has an id using the following syntax

@+id/identifier

(has Android define a global id automatically)

35
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Step 3

Define what happens when the two buttons are clicked

New concepts

Create an Intent

Intent i = new Intent(this, ScreenOne.class);

Where ScreenOne is a new Activity

findViewById(resource_id): looks up widgets

OnClickListener : implement interface

36
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Step 4

Create the other two Activities

Use File ⇒ New ⇒ Class in Eclipse

Add new classes to the src directory with the 
package org.example.screenswitcher and the 
superclass android.app.Activity. Do not generate 
method stubs.

Name one activity ScreenOne and the other 
ScreenTwo

37
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Step 5

Implement onCreate() for both of the new activities and 
create layout files for both

Both layout files will go in res/layout

Use File ⇒ New ⇒ Android XML File

Define layout for both screens… both will have a title and 
a button. They will each have a different background color

Colors will be defined in res/values/colors.xml

38
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Step 6

Update the Android Manifest to “know” about the other 
two activities

You can now run the application and switch among the 
various screens

Note: the ScreenTwo activity has been augmented to 
assign ids to each instance created and it prints out life 
cycle events with the id so we can see how many 
instances are created

39
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Discussion

As we can see from the output of ScreenTwo’s Log messages, 
each time we invoke

startActivity(new Intent(this, ScreenTwo.class));

we create a completely new instance of ScreenTwo

Even though “screen two” as a logical concept suggests that 
there should only be one “screen two activity”, a separate 
activity gets created each time we visit it

This has implications for application design

We don’t want to start “big” activities multiple times

40
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Wrapping Up (I)

We’ve had a brief introduction to the Android framework

Big picture: Apps running in Dalvik on top of Linux

Application != Process

Application equals set of activities (screens)

Applications use Intents to start new activities

be it activities within the same application or to 
invoke a system activity (e.g. view web page)

41
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Wrapping Up (II)

After the midterm, we’ll return to the Android framework

More comprehensive example

We’ll see how to pass data between activities using 
Intents

Getting user input via forms and dialogs

Accessing the file system and the network

And more…
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Coming Up Next

Lecture 12: Introduction to Objective-C

Lecture 13: Introduction to iOS

Homework 4 Due on Monday

Lecture 14: Review for Midterm

Lecture 15: Midterm
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